Skip navigation

Contract: Login Login / Search

Charging system

Post

I ck out the charger to day it's working fine it was at 14 volts load tested to12 and was back up when I left

Last edit: by Tippodriver


400 ' is high enough to get were you are going
Back to the top

Post

The field charger is good, it just doesn't have the capacity to charge a couple of airplane batteries at the same time. It looks like we need a new battery. :'(

Onward and Upward.
Back to the top

Post

On Thursday the starting voltage of the system was 14. After up to 3 chargers had been working for a while, the voltage dropped to about 12. That's when we started to get the input voltage error from the chargers. If we let the system rest for a short while the system recovered enough to sustain the draw from a charger. Not multiple ones. Voltage at that time was between 12 and 13 volts. Most likely it is a charging station battery issue.  Three chargers drawing on the storage battery should not be a serious load.

Thermals---I need thermals!
Back to the top

Post

Anything new on the charging system?

Thermals---I need thermals!
Back to the top

Post

Carl picked up a new battery for the charger yesterday fixed the drag waterwagen and roller I got the weeds sprayed looks like we're ready for some flying

400 ' is high enough to get were you are going
Back to the top

Post

*I'll donate and install a new windsock if somebody knows where to find one?
Back to the top

Post

Thank you Carl and Cliff for all the work you did yesterday.

Thermals---I need thermals!
Back to the top
1 guest and 0 members have just viewed this.